• 首页 首页 icon
  • 工具库 工具库 icon
    • IP查询 IP查询 icon
  • 内容库 内容库 icon
    • 快讯库 快讯库 icon
    • 精品库 精品库 icon
    • 问答库 问答库 icon
  • 更多 更多 icon
    • 服务条款 服务条款 icon

数据结构实验:链表六有序链表的建立

武飞扬头像
wx646db0e245a37
帮助1

数据结构实验之链表六:有序链表的建立

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6 33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    struct node *head, *p, *tail, *q;
    int n, i, t;
    scanf("%d", &n);
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    for(i = 1; i <= n; i  )
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
   for(p = head->next; p != NULL; p = p->next)
   {
       for(q = p->next; q != NULL; q = q->next)
       {
           if(p->data > q->data)
           {
               t = q->data;
               q->data = p->data;
               p->data = t;
           }
       }
   }
    for(p = head->next; p->next != NULL; p = p->next)
    {
        printf("%d ", p->data);
    }
    printf("%d\n", p->data);
    return 0;
}

这篇好文章是转载于:学新通技术网

  • 版权申明: 本站部分内容来自互联网,仅供学习及演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,请提供相关证据及您的身份证明,我们将在收到邮件后48小时内删除。
  • 本站站名: 学新通技术网
  • 本文地址: /boutique/detail/tanhibiecb
系列文章
更多 icon
同类精品
更多 icon
继续加载